Library bug in Syberia 2 on Android

All technical issues here please :)

Moderators: gail, phil1908

Library bug in Syberia 2 on Android

Postby Exolon » Mon 30 Mar 2015 06:31


unfortunately I think I encountered a bug in Syberia 2 on Android.

I used the large hook in the Monastery to light the correct candles, then I place the stained-glass mammoth over the window and clicked on each of the four panels surrounding it in turn - bottom, left, top, right. This should focus a mammoth's image on the opposite wall of the library, but this did not happen. I only see a cutscreen with the library wall but there appears no mammoth's image. The windows containing the stained-glass stays full opened and I can't proceed.

I'm Playing on a Galaxy Note 3 in German.

What can I do? Is there a fix for this?


Posts: 1
Joined: Mon 30 Mar 2015 06:28

Re: Library bug in Syberia 2 on Android

Postby LlamaLlamaLamp » Fri 17 Apr 2015 13:55

I am experiencing the same issue. After placing the mammoth glass and pushing the correct combo buttons, the area lights up but it doesn't show the mammoth outline and it doesn't show a magnifying glass icon where the mammoth eye should be.

HTC M8 4.4.4
Posts: 1
Joined: Thu 16 Apr 2015 16:05

Re: Library bug in Syberia 2 on Android

Postby GMC » Thu 8 Oct 2015 15:00

Hi everyone! I'm playing on Steam on a MacBook with Mavericks and I'm experiencing the exact same issue.

I thought I was stuck, so I checked a walkthrough, but it turns out it's a bug.

It's exactly how you describe: you place the stainglass mammoth, you push the four things clockwise starting from the bottom one, and a cutscene seems to be about to happen, but then nothing really happens and there's no mammoth projected on the wall.

Hoping this bug will be solved soon.

Also, when I reload, I restart from a previous state, not the latest one, so I have to redo everything from the previous time I saved. :-/
Posts: 1
Joined: Thu 8 Oct 2015 14:51

Re: Library bug in Syberia 2 on Android

Postby kaotikinfinity » Thu 4 May 2017 21:34

im on ps3 an also stuck with this bug :(
Posts: 1
Joined: Thu 4 May 2017 21:30

Re: Library bug in Syberia 2 on Android

Postby Siren Drake » Tue 6 Jun 2017 11:27

The Sequence that worked for me was:
Top, Right, Bottom, Left.

But that does raise an interesting design point. There's no clue for this "puzzle" that I know of. Apparently, players were EXPECTED to brute force the solution. That's not what I call a puzzle where you're figuring something out.
Siren Drake
Posts: 72
Joined: Sat 30 Jul 2016 00:10

Return to EN - Technical Support

Who is online

Users browsing this forum: Bing [Bot] and 1 guest