Installed CD-Rom but flickers and doesn't open

All technical issues here please :)

Moderators: gail, phil1908

Installed CD-Rom but flickers and doesn't open

Postby SpeckledWhite » Wed 24 May 2017 19:21

Computer: ASUS X550Z

Tried altering settings of compatibility still won't open. Neither Syberia I or II. I was given a set of patches but I don't think those work? anymore or need a more direct link.. Idk if Patches allot opening the Drive. It flickers in and out when trying to open it and stops.

This is a gaming computer and should be compatible with all the necessary functions in order to run it. Especially Syberia 3.. I haven't bought Syberia 3 yet or tried it but maybe I and II are too old or wont work or maybe I deleted their contents despite the fact that I can install it..

If all else fails I suppose I could pay for it on the Steam engine but am really disappointed. :-/

Help Please?
Posts: 2
Joined: Wed 24 May 2017 19:16

Return to EN - Technical Support

Who is online

Users browsing this forum: No registered users and 1 guest